speicherdienste:netzlaufwerke:linux
Unterschiede
Hier werden die Unterschiede zwischen zwei Versionen angezeigt.
| Beide Seiten der vorigen RevisionVorhergehende ÜberarbeitungNächste Überarbeitung | Vorhergehende Überarbeitung | ||
| speicherdienste:netzlaufwerke:linux [06:25 12. April 2024 ] – Christoph Niems | speicherdienste:netzlaufwerke:linux [09:02 04. September 2026 ] (aktuell) – [mounten per Kommandozeile] Christian Marg | ||
|---|---|---|---|
| Zeile 37: | Zeile 37: | ||
| ===== mounten per Kommandozeile ===== | ===== mounten per Kommandozeile ===== | ||
| Dieser Abschnitt beschreibt, wie die Netzwerkfreigabe per Kommandozeile gemountet werden kann. | Dieser Abschnitt beschreibt, wie die Netzwerkfreigabe per Kommandozeile gemountet werden kann. | ||
| - | Er richtet sich an Anwender, die zumindest grundlegende Kenntnisse im Umgang mit dem Befehl //mount// haben. | + | Er richtet sich an Anwender, die zumindest grundlegende Kenntnisse im Umgang mit der Kommandozeile und '' |
| - | Eine Einleitung zu mount gibt es beispielsweise im [[https:// | + | |
| - | Die folgenden Befehle müssen mit root-Rechten ausgeführt werden, beispielsweise durch ein vorangestelltes //sudo//. | + | |
| - | Zum mounten gibt man folgenden Befehl ein: | + | Um das Windows-Home (//Laufwerk '' |
| - | + | ||
| - | mount -t cifs // | + | |
| + | mkdir -p / | ||
| + | | ||
| Hierbei muss //abc42// durch den TUC-User bzw. den einzubindenden freigegebenen Ordner ersetzt werden. | Hierbei muss //abc42// durch den TUC-User bzw. den einzubindenden freigegebenen Ordner ersetzt werden. | ||
| /// | /// | ||
| - | Möchte man sein Passwort | + | Möchte man sein Passwort |
| - | | + | <code bash> |
| + | read -p " | ||
| + | </ | ||
| + | |||
| + | Die Endung '' | ||
| + | |||
| + | Danach kann man diese Datei im Mount-Kommando übergeben: | ||
| + | |||
| + | mkdir -p / | ||
| - | Hierbei muss man // | ||
| - | Zu beachten ist, dass das Passwort dann je nach Konfiguration des Rechners in .bash_history oder einer ähnlichen Datei gespeichert wird! | ||
| - | Dies kann ein Sicherheitsrisiko darstellen. | ||
| Will man die Einbindung lösen führt man wie gewohnt den folgenden Befehl aus: | Will man die Einbindung lösen führt man wie gewohnt den folgenden Befehl aus: | ||
| - | umount /mnt/nas | + | |
| Weitere Informationen gibt es in den folgenden man-Pages: | Weitere Informationen gibt es in den folgenden man-Pages: | ||
| - | * mount.cifs | + | * mount.smb3 |
| * mount | * mount | ||
| * umount | * umount | ||
| - | |||
| - | Bei einem Fehler ähnlich wie dem Folgenden ist es ratsam in den dmesg output zu schauen. Meistens wird der Fehler durch Versionsunterschiede ausgelöst. | ||
| - | |||
| - | mount error(95): Operation not supported | ||
| - | |||
| - | Der Fehler lässt sich umgehen wenn man explizit die CIFS Version angibt: | ||
| - | |||
| - | mount -t cifs // | ||
| - | |||
| {{tag> [mitarbeitende]}} | {{tag> [mitarbeitende]}} | ||
speicherdienste/netzlaufwerke/linux.1712903140.txt.gz · Zuletzt geändert: von Christoph Niems
